Announcement

Collapse
No announcement yet.

ZTE MF636 - Disable diagnostic port

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ZTE MF636 - Disable diagnostic port

    Okay so I ran dc-unlocker, it detected my modem, log below -

    DC - Unlocker 2 Client 1.00.0565

    Detecting card :

    selection :
    manufacturer - ZTE modems
    model - Auto detect (recommended)

    Found modem : MF636BP USB STICK
    Model : ZTE MF636
    IMEI : 355630021125005
    Firmware : T02
    Compile date / time : Sep 08 2008 11:34:32
    Chipset : Qualcomm MSM6290
    NAND Flash : SAMSUNG_K91G08
    SIM Lock status : unlocked

    ================================================== =================
    For some stupid reason I clicked "Enable Diagnostic Port" and now my computer won't recognise my modem. It picks up ZTE Diagnostics Interface (COM9) and ZTE NMEA Device (COM10) in device manager.

    Is there a way to disable diagnostic port and go back to modem mode?
    Any help would be greatly appreciated.
  • #2

    Try to detect modem and under detected modem copy AT+ZCDRUN=F and press enter.

    Comment

    • #3

      yes, i think if we make Enable Diagnostic Port modem canot back to autorun mode. this make dashboard not work.

      need feature to Disable Diagnostic Port.

      Comment

      • #4

        Originally posted by opik fixcell View Post
        yes, i think if we make Enable Diagnostic Port modem canot back to autorun mode. this make dashboard not work.

        need feature to Disable Diagnostic Port.
        Please read my previous message how to dissable it

        Comment

        • #5

          Originally posted by Vincentas View Post
          Please read my previous message how to dissable it
          yes sir
          i have try that,

          AT+ZCDRUN=F

          exit download mode result(0:FAIL 1:SUCCESS):1
          OK

          AT+ZCDRUN=N

          close diag port(0:FAIL 1:SUCCESS):1
          OK

          Comment

          • #6

            My modem and diagnostic port both are not detected on my laptop.

            I tried the same AT+ZCDRUN=F command to disable the diagnose port. This completed successfully. But after that only once my modem was detected, the next time I plugged in the device modem was undetected. My laptop can now only detect the virtual cd-rom

            Comment

            • #7

              Originally posted by kr_yogesh41 View Post
              I tried the same AT+ZCDRUN=F command to disable the diagnose port. This completed successfully. But after that only once my modem was detected, the next time I plugged in the device modem was undetected. My laptop can now only detect the virtual cd-rom
              try manual eject ur cd drive.

              Comment

              • #8

                Originally posted by opik fixcell View Post
                try manual eject ur cd drive.
                ya i did that.. but nothing happend. whenever i pluggin the device i can only detect the cdrom. not the modem. make of my modem is zte k3570-z

                Comment

                • #9

                  same problem...

                  can someone help how disable diagnose port

                  Comment

                  • #10

                    Originally posted by opik fixcell View Post
                    yes sir
                    i have try that,

                    at+zcdrun=f

                    exit download mode result(0:fail 1:success):1
                    ok

                    at+zcdrun=n

                    close diag port(0:fail 1:success):1
                    ok


                    how to send at+zcdrun=f command in modem please explane

                    thanks you

                    Comment

                    • #11

                      Originally posted by PRINCE MOBILE View Post
                      how to send at+zcdrun=f command in modem please explane

                      thanks you
                      Just type it after the detect/unlock text and press Enter.

                      Comment

                      • #12

                        Originally posted by zachary View Post
                        Okay so I ran dc-unlocker, it detected my modem, log below -



                        For some stupid reason I clicked "Enable Diagnostic Port" and now my computer won't recognise my modem. It picks up ZTE Diagnostics Interface (COM9) and ZTE NMEA Device (COM10) in device manager.

                        Is there a way to disable diagnostic port and go back to modem mode?
                        Any help would be greatly appreciated.


                        just paste AT+ZCDRUN=F this code in dc-unlocker and press enter

                        after succses remove and insert dongle again cd drive run

                        i have same problem and i solved today

                        Comment

                        • #13

                          Originally posted by Gintas View Post
                          Just type it after the detect/unlock text and press Enter.
                          thanks it's work

                          Comment

                          • #14

                            still can't disable the diagnostic port on my zte modem

                            I have already uninstalled the software of my modem,now i can't install it back,i tried using AT+ZCDRUN=F but the dc unlocker won't even recognoise my modem.Please help

                            Comment

                            • #15

                              Originally posted by coolkings View Post
                              I have already uninstalled the software of my modem,now i can't install it back,i tried using AT+ZCDRUN=F but the dc unlocker won't even recognoise my modem.Please help
                              Try to install it manually.
                              Also, you do not need to detect modem by dc-unlocker. Only select model, enter port numbers frmo device manager and then try to enter AT+ZCDRUN=F command.

                              Comment

                              Working...
                              X