Announcement

Collapse
No announcement yet.

flashing help please

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • flashing help please

    Hi hope someone can advise as I'm loosing the will to live :-(

    I've a mate 8 NXT-L29C636 which I believe is asia region although I've from the UK

    I was running stock android 6 with EMUI 4.0
    When I ask it to check for any update, it always came back with no updates.
    I saw plenty of threads saying they had updated to android 7 and 8 and how they done it.
    So I downloaded Firmware Finder from Google play and without too much difficulty managed to start installing firmware. That's when my problems started :-(
    This was two weeks ago and I've been spending 100+ hours trying to recover.
    I think it failed a 5% or something and since then my phone will not boot properly.
    I can only fastboot it and sometimes to erecovery and EMUI to wipe/factory reset

    Searching forums it seems DC Phoenix was the only software that could help so I bought it.
    So far I've tried flashing firmware from DC-Unlocker site in standard more but all goes ok with success for all the partitions but it requires the phone to put into upgrade mode, something my phone never does and I can't force it.
    So that leaves me with advanced mode, again all successful but booting the phone just gives the huawei logo then reboots again :-(

    I've tried different stock roms NXT-L29C636 but they all claim successful but still can't boot my phone
    I've followed the steps in DC-Phoenix instructions to no avail.
    The last step today meant shorting a pin to ground to force the phone into a mode when it was seen as windows as Huawei USB COM device, which seemed to work.
    The instructions claimed I can use any NXT board flash as they're all the same and again all successful i used
    NXT-AL10_M00A102_Board Software_Global _Nonspecific_Android 6.0_EMUI 4.0_05021WLB_4.dtwork
    but the log file now says build is;
    Build number: HLNXTAL10BM00A102
    Model: HUAWEI NXT-L29
    Battery state: 3249mv

    from
    Build number: :NXT-L29C432B192
    Model: HUAWEI NXT-L29
    Battery state: 7035mv

    So my question is am I using the wrong firmware? It is always successful so I don't think it's bricked but I can't work out what I'm doing wrong.
    Other things to mention is pressing vol - and vol + and power with sd card and dload doesn't work either.

    Sorry for long post and thanks for reading
    Any help very much appreciated
  • #2

    So finally fixed this with DC-Phoenix - great bit of software - lacking full documentation though :-(

    What I did to fix was put my phone into testpoint mode - note you only have to short the pin to ground (or use a 10k resistor to be safer like I did) for short while when pressing the power button.
    You'll know when your phone is in this mode and the screen will stay blank and in device manager in Windows it will display Huawei USB COM 1.0 (COM7) and you can unshort the pad.

    Next I flashed my bootloader and oeminfo
    Then I flashed the firmware
    When DC-Phoenix wants to put the phone in update mode, this was the bit I was having problems with
    Looking a device manager again I found two unknown devices with a yellow warning, this was because windows didn't have the driver for the phone in this mode.
    Fixing was easy, just told windows to look for a driver in the folder where Hi-Suite was installed and it installed TWO Virtual COM ports
    From there DC-Phoenix could 'see' the phone and carried on.
    The phone displayed updating...and stuck at 5% until the drivers were installed. Then it carried on as normal up 100% took about 5-10 mins
    Then the phone booted ok,
    Phew

    HTH's someone

    Comment

    Working...
    X