Announcement

Collapse
No announcement yet.

Huawei Y6 SCL-L21 hard brick help please

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Huawei Y6 SCL-L21 hard brick help please

    Hi there,

    I'm completely new to this, so sorry in advance when I ask things that are obvious for a more experienced person. I tried to read and follow all the information and tutorials as best I could, but I'm at my wits' end.

    I have a Huawei Y6 SCL-L21, which had been stored away for over a year. Everything was fine last I used it, now it's completely dead. Doesn't switch on, doesn't charge. When I connect it to a recharger or computer all I get is a flashing red light. No reactions whatsoever when pressing or holding any buttons, single or combined.

    Connected via USB to the computer, it registers as "Qualcomm HS-USB QDLoader 9008 (COM3)" in the device manager.

    My understanding of the problem, after some research on the internet, is that the battery ran dry over time and now the phone is hard bricked. (Why does that happen at all?!?) I tried to put original rom software, which I found on the internet, onto a micro SD and inserted it into the phone, but since the phone doesn't even switch on at all, this method of flashing is apparently impossible.

    Therefore I now wanted to use DC Phoenix:

    I installed the Qualcomm drivers on my PC.
    I bought the coins necessary to flash my phone.
    I have the original rom which I mentioned above.
    When I now connect my phone to the PC, run DC Phoenix, select the update.app from the rom package, DC Phoenix tells me

    "Looking for a device in upgrade mode
    No devices detected in upgrade mode
    No device detected to update"

    What am I doing wrong?
    Do I have the wrong software?
    Anything else I'm overlooking?

    Any help would be greatly appreciated!! Thanks...
  • #2

    If battery is not charged then our solutions definitely won't work.

    Comment

    Working...
    X