Announcement

Collapse
No announcement yet.

Honor 9 STF-L09 Bootloader code could not be read

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Honor 9 STF-L09 Bootloader code could not be read

    Hi,
    I successfully have read bootloader code for Honor 8 (FRD-L08) phones, and now tried for Honor 9 (STF-L09), but getting an error:

    DC - Unlocker 2 Client 1.00.1431
    Detecting phone :
    selection :
    manufacturer - Huawei phones
    model - Auto detect (recommended)
    Found Applications port COM16
    ================================================== =================
    Check account status
    User : thelittlego
    Credits left : 4
    Activated features:
    Software debugger
    Unlock Auto detect (recommended) cost 4 cr
    ================================================== =================
    Reading bootloader code...
    Not supported/unknown chipset!
    ================================================== =================

    According to this page read bootloader code is supported for STF-L09:
    https://www.dc-unlocker.com/android-feature-table
    But on this page the Honor 9 ist not listed:
    https://www.dc-unlocker.com/supporte.../huawei_phones

    So, is it because of the new firmware 9.1.0.210 (EMUI 9.1 and Android 9) - I can downgrade if required, or is Honor 9 not supported?

    Thanks in advance

  • #2

    Correct, android 9 and later not support for it, it may not work on android 8 as well depending on security patch it has.

    Comment

    • #3

      Ok, donwgraded to firmware STF-L09 8.0.0.385(C432) with Android security from 1. Feb 2019 and got the same result.
      Will try to downgrade further ... do you happen to know what firmware / security patch version is working?

      Comment

      • #4

        No, sadly i do not know this Basically version that it came out with - never been updated.

        Comment

        • #5

          Originally posted by thelittlego View Post
          Ok, donwgraded to firmware STF-L09 8.0.0.385(C432) with Android security from 1. Feb 2019 and got the same result.
          Will try to downgrade further ... do you happen to know what firmware / security patch version is working?
          In your case, you need to use only the board firmware, and flash through the testpoint
          otherwise it is not possible to get an unlock code

          Comment

          Working...
          X