Announcement

Collapse
No announcement yet.

GlobeSurfer Icon 7.2 reinitializing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GlobeSurfer Icon 7.2 reinitializing

    I have succesfully (I hope) unlocked a GlobeSurfer Icon 7.2 modem, which was locked to Orange RO. When I'm using a Vodafone RO sim, it recognizes the sim, connects to the network, works very well for a few seconds (10 - 20 sec) then it tries to reinitialize and... that's it. It stays in this state until I get bored and remove it. The white led blinks very fast, like it doesn't have or doesn't recognize the sim, as far as I think.
    Any ideea why? And how to fix the problem?
    I'm happy that I have paid 15 euros to unlock the modem, but I'm not that happy that now I can't use it...
  • #2

    Now all time led's flashing ?Or after 10-20 seconds usage ?
    You use GTconnect software ?

    Comment

    • #3

      At first, it acts like a "normal" modem, with the original sim - it flashes like it normally did.
      I'm using the GT software, of course. Any other software doesn't work - Internet Everywhere or Vodafone's VMC - they don't recognize the modem.
      It starts like it should, searches for the network, finds it, connects to it (3G or HS), then the modem dissapears for a couple of seconds and the GT software reports that the modem is reinitializing...
      I have managed to download something during the first few seconds, and browse through a few pages, so it works. I've tried it with both my desktop and my laptop. The same thing happens. The led starts flashing really fast and... that's it. The interesting thing was that Windows report the connection as 7.2, not 3.6, but the modem with the original Orange sim works at 3.6.

      Comment

      • #4

        Then after this fast flashing your modem must work till reinsert ?
        I think this is something wrong with your modem, you can try upgrade firmware ... maybe it helps.

        Comment

        • #5

          After I remove the modem and plug it back in, the same thing happens all over again... finds the network, connects, works 10-20 seconds, then disappears and reappears in the device manager immediately and starts flashing fast and "initializing" - but it never stops, once the led starts flashing.
          The modem worked fine for over a year, with the Orange sim, so I really don't think there's something wrong with it. And I've tried to find firmware updates, but neither the Option site nor the Orange site don't say anything about a firmware.
          So... what now? The dc-unlocker site didn't say "pay 15 euros and unlock your modem for 20 seconds"!

          Comment

          • #6

            Same problems have option 3g+, option, fusion models and gtmax (older models). Look there :
            http://www.3g.co.uk/3GForum/showthread.php?t=41893

            Firmware is on our web page. If Your modem have hardware problem (example memory IC) after upgrade it can stop work totally.

            We not modify your modem firmware (if you try tell it), our software read code and send code to modem using totally safe way.

            Comment

            • #7

              I know what the dc software does. I did it with an expresscard by myself and it worked fine. I didn't say that your software is responsible, but I would like to know why this happened right after using it on my modem.
              The firmware on your site doesn't apply for my modem, or doesn't want to. My firmware is 2.1.2Hd. Do you know where I could get a firmware that works? Or what should I try?
              I'm sorry, but the link you gave me didn't help, because it refers to data cards, not usb modems (or at least from what I could read there). And I'm sure the modem's firmware is not the problem, because it worked perfectly since the spring of 2007 until last night, just before the unlock.
              I don't know what the problem could be - the firmware isn't, the unlocking procedure should be safe... I wanted to know if you encountered the same problem before, and if someone solved it. It may have to do with the networks, the sims, the settings...
              The thing that made me think was the 7.2Mbps connection, which was previously unavailable with the original sim.
              Anyway, if you know where I could find a firmware for this modem, it would be very good.

              Comment

              • #8

                PCMCIA modem, data card or usb modem all are same (use same cpu, similar firmware). Link is for show users have similar problems with older Option modems. Newest option modems not have this problem.

                Firmware on our page compatible with your modem !
                Just if your modem are branded , then updater not begins.
                If leds begin flash very fast, then your modem are in emergency download mode. In this mode if you start upgrade, then upgrade process begins.

                I not see same problem (that working 20 seconds), but i see many modems (also like your) with all time fast flashing leds. Firmware help not all time

                Comment

                • #9

                  Indeed, my modem is branded. I didn't came across this information about the branding and the firmware before, that's why I asked you so many questions.
                  I did what you suggested and now it's updating!
                  I hope this will solve the problem!
                  I'll write another post, to let you know.
                  Thanks

                  Comment

                  • #10

                    Well, so far it works!!!
                    5 minutes and counting...
                    Thanks again for the help! I've learned something new today
                    Will recommend your site, if anyone needs unlocking their modem.

                    Comment

                    Working...
                    X