No announcement yet.

Option GTM378 firmware request

  • Filter
  • Time
  • Show
Clear All
new posts

  • Option GTM378 firmware request

    Hi everyone,

    I have an Option GTM378 Mini-PCIe module that is supposed to have integrated GPS as well as voice capabilities. However, I'm having a really hard time getting any of these to work. Since my installed firmware is "2.1.2Hd (Date: Feb 20 2007, Time: 13:00:52)", I'm suspecting that the problem is that the firmware is out of date. Can someone direct me to where I can download the latest firmware for this module as well as a flashing program to program it into the unit? I've already checked the download section here for the Option hardware and did not see anything compatible. Also, I'd like to get more up-to-date (meaning useful) software for this device as well. I've tried to install the 'option_modules' package from the download section, but it will not install (it fails with "internal error 2803. Error_Dialog").


    PS: DC-unlock identifies this unit as "GlobeSurfer ICON 7.2" ... I'm using Vista ultimate 64-bit ... The computer this device is attached to is a Dell 1720 ... (a.k.a. Vostro 1700)
  • #2

    Drivers for 378 64bit


    Sorry for OT
    I've spent over a week looking for the drivers for this chip for 64bit. Please be so kind and let me know where can I get them.

    Thank you.


    • #3

      Try it.


      • #4


        just checked this site for help, im having problems with my GPS and on My unlocked GTM 378, it looks as if i have too lower firmware 2.3.2Hd tried the link on the previous message and the link is dead. Can anyone please help post new link.

        Many Thanks


        • #5


          • #6


            Thanks again for the link. I am still having problems.Downloaded Superfire GTM378,

            Everty time i run the application it keeps say cannot up date this card.

            In the Error log its says
            Do product GTM378E
            Do code M00201-10848
            Do Unsupported card (M00201-10848)

            This run on Windows 7 64 bit on Lenovo X61 tablet

            thanks for any help..


            • #7


              i did a lot of google-ing and found the asnwer. i suspect i had a branded card so got a hex editor patched the superfire.exe

              Im now half way though updating the card..


              • #8

                bendgrimes - Try out the firmware update from Option GlobeSurfer iCON 7.2 - Click the on the drop down box and select "Firmware".

                To enable the GPS function see this link: How to enable and use the GPS functionality on your GTM378 module?.


                • #9

                  Originally posted by yaylol View Post
                  hi all,

                  I have downloads superfire to option gtm 378 (SuperfireGTM378_FW_2.5.1Hd). I try to carry on but that happening emerging writing


                  the application is examining your system and device

                  the detected device canot be is with this's update programs. please insert an appropriate device and clik Next to try again

                  fault what does I do, please its assistive how to utilize superfire this. there is diagnostic even modem I am

                  Product Name: GlobeTrotter Connect
                  Product Version: 3.1.0. 1162
                  Hardware is Test
                  Card name: GTM378
                  Driver version: 4.0. 17. 0
                  Application is port: COM3
                  Card is number's serial: ***xxxK0FH
                  Firmware version: 2.3. 3Hd (Date: Jul 17 2007, Time: 15:49:23)
                  Hardware version: 3. 1
                  IMEI number: 35xxxxxxxxxxxxx
                  ICCID number: 89xxxxxxxxxxxxxxxxxx
                  Phone number (s )
                  Operational is Test
                  code's pin state: Ready
                  Network name: 3
                  Network selection is mode: Automatic
                  Signal strength: 20,0
                  Network settings
                  CS network registration: Registered
                  PS network registration: Registered
                  PS network attachment: Attached
                  APN (s ): xxxxx

                  this modem from BOUYGUES TELECOM

                  if there is that can help me, I utter a lot of gratitude.

                  best regards,