Announcement

Collapse
No announcement yet.

Option Icon 225 update error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Option Icon 225 update error

    Hello,


    I've downloaded the Option software to update my old Icon 225 (Orange branded) firmware but the process is stoped because "the device cannot be updated"

    The device is unlocked.

    Actual firmware : 2.5.13Hd
    Firmware requested : 2.5.24Hd

    I've activated the log file :

    4.446: CCgHelper::RetrieveCardInfo, CgEnterExclusiveMode: OK.
    4.446: Cg: CardGnome v1.0 (Unicode static library, loglevel=1)
    4.446: Cg: Loading resources from resource 0x400000 (EXE)
    4.462: Cg: Successfully loaded information for 59 cards
    4.462: Cg: Listener thread started
    4.462: Cg: New listener thread duty is 'Idle'
    4.462: Cg: Notification window initialized
    4.462: Cg: Checking actual state of the system at startup...
    4.462: Cg: Card state has been silently set to CardStateStopped
    4.478: Cg: No PCMCIA cards detected, rc=0xd
    4.478: Cg: Found USB device with hardware ID [USB\ROOT_HUB&VID8086&PID27CA&REV0002,U SB\ROOT_HUB&VID8086&PID27CA,USB\ROOT_HUB], checking it...
    4.478: Cg: Found USB device with hardware ID [USB\ROOT_HUB&VID8086&PID27C8&REV0002,U SB\ROOT_HUB&VID8086&PID27C8,USB\ROOT_HUB], checking it...
    4.493: Cg: Found USB device with hardware ID [USB\ROOT_HUB&VID8086&PID27CB&REV0002,U SB\ROOT_HUB&VID8086&PID27CB,USB\ROOT_HUB], checking it...
    4.493: Cg: Found USB device with hardware ID [USB\ROOT_HUB&VID8086&PID27C9&REV0002,U SB\ROOT_HUB&VID8086&PID27C9,USB\ROOT_HUB], checking it...
    4.493: Cg: Found USB device with hardware ID [USB\ROOT_HUB20&VID8086&PID27CC&REV0002 ,USB\ROOT_HUB20&VID8086&PID27CC,USB\ROOT_H UB20], checking it...
    4.493: Cg: Found USB device with hardware ID [USB\VID_0A5C&PID_2101&REV_0354,USB\VID_0A5 C&PID_2101], checking it...
    4.493: Cg: Found USB device with hardware ID [USB\VID_0AC8&PID_C326&REV_0100,USB\VID_0AC 8&PID_C326], checking it...
    4.493: Cg: Found USB device with hardware ID [USB\VID_0AC8&PID_C326&REV_0100&MI_00,U SB\VID_0AC8&PID_C326&MI_00], checking it...
    4.493: Cg: Found USB device with hardware ID [USB\VID_0AF0&PID_6971&REV_0000,USB\VID_0AF 0&PID_6971], checking it...
    4.493: Cg: DevNode 0xa18 status is 0x180600a, problem# is 0 (active)
    4.524: Cg: Found PCI device with hardware ID [PCI\VEN_11AB&DEV_4354&SUBSYS_CA00144D& REV_13,PCI\VEN_11AB&DEV_4354&SUBSYS_CA0014 4D,PCI\VEN_11AB&DEV_4354&CC_020000,PCI\VEN _11AB&DEV_4354&CC_0200], checking it...
    4.540: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27C4&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27C4&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27C9&CC_0C0300,PCI\VEN _8086&DEV_27C9&CC_0C03], checking it...
    4.540: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27CA&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27CA&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27CA&CC_0C0300,PCI\VEN _8086&DEV_27CA&CC_0C03], checking it...
    4.540: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27CB&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27CB&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27CB&CC_0C0300,PCI\VEN _8086&DEV_27CB&CC_0C03], checking it...
    4.540: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27CC&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27CC&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27CC&CC_0C0320,PCI\VEN _8086&DEV_27CC&CC_0C03], checking it...
    4.540: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27D0&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27D0&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27D0&CC_060400,PCI\VEN _8086&DEV_27D0&CC_0604], checking it...
    4.556: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27D4&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27D4&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27D4&CC_060400,PCI\VEN _8086&DEV_27D4&CC_0604], checking it...
    4.556: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27D8&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27D8&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27D8&CC_040300,PCI\VEN _8086&DEV_27D8&CC_0403], checking it...
    4.556: Cg: Found PCI device with hardware ID [PCI\VEN_8086&DEV_27DA&SUBSYS_CA00144D& REV_02,PCI\VEN_8086&DEV_27DA&SUBSYS_CA0014 4D,PCI\VEN_8086&DEV_27DA&CC_0C0500,PCI\VEN _8086&DEV_27DA&CC_0C05], checking it...
    4.556: Cg: ------------------------------------------------------------------------------------------------------
    4.556: Cg: Supported card Racer72 detected with hardware ID [USB\VID_0AF0&PID_6971&REV_0000] & devnode 0xa18
    4.556: Cg: ------------------------------------------------------------------------------------------------------
    4.556: Cg: Modem detection method is set to ModemDetMethodDefaultPolling
    4.556: Cg: Application port detection method is set to AppPortDetMethodDefaultPolling
    4.556: Cg: Application2 port detection method is set to AppPortDetMethodDefaultPolling
    4.556: Cg: Debug port detection method is set to DbgPortDetMethodDefaultPolling
    4.556: Cg: Card state changed to Starting
    4.556: Cg: Detection timeout timer started with 300000 msec timeout
    4.556: Cg: Polling timer started with 1 sec frequency
    4.556: Cg: This card has a modem device and has a WWAN NIC device
    4.556: Cg: This card has a primary application port
    4.556: Cg: Searching for modem [GlobeTrotter] with parent 0xa18
    4.571: Cg: Checking modem #0 [GlobeTrotter HSxPA - Modem Interface]
    4.571: Cg: DevNode 0x1384 status is 0x180600a, problem# is 0 (active)
    4.587: Cg: Corresponding modem GlobeTrotter HSxPA - Modem Interface found with devnode 0x1384
    4.587: Cg: Searching for port [Application Interface] with parent 0xa18
    4.602: Cg: Checking port #0 [GlobeTrotter HSxPA - Application Interface (COM4)]
    4.602: Cg: DevNode 0x12f4 status is 0x180600a, problem# is 0 (active)
    4.602: Cg: Corresponding application port found on \\.\COM4 with devnode 0x12f4
    4.602: Cg: Final port could be opened successfully
    4.618: Cg: This card has NO smart card reader device
    4.618: Cg: Searching for network adapter [GlobeTrotter] with parent 0xa18
    4.649: Cg: Checking network adapter #0 [Carte Microsoft ISATAP]
    4.712: Cg: Checking network adapter #1 [Carte Microsoft ISATAP]
    4.758: Cg: Checking network adapter #2 [Carte Microsoft ISATAP]
    4.774: Cg: Checking network adapter #3 [Carte Microsoft ISATAP]
    4.790: Cg: Checking network adapter #4 [Carte Microsoft ISATAP]
    4.852: Cg: Checking network adapter #5 [WAN Miniport (IKEv2)]
    4.883: Cg: Checking network adapter #6 [Microsoft Teredo Tunneling Adapter]
    4.914: Cg: Checking network adapter #7 [Miniport WAN (L2TP)]
    4.930: Cg: Checking network adapter #8 [Miniport WAN (Moniteur rÚseau)]
    4.992: Cg: Checking network adapter #9 [Miniport WAN (IP)]
    5. 24: Cg: Checking network adapter #10 [Miniport WAN (IPv6)]
    5. 55: Cg: Checking network adapter #11 [Miniport WAN (PPPOE)]
    5. 70: Cg: Checking network adapter #12 [Carte asynchrone RAS]
    5. 86: Cg: Checking network adapter #13 [Miniport WAN (PPTP)]
    5.102: Cg: Checking network adapter #14 [Miniport WAN (SSTP)]
    5.102: Cg: Checking network adapter #15 [GlobeTrotter HSxPA - Network Interface]
    5.102: Cg: DevNode 0x12ac status is 0x180600a, problem# is 0 (active)
    5.102: Cg: Corresponding WWAN network adapter GlobeTrotter HSxPA - Network Interface found with devnode 0x12ac (NetCfgInstanceId={C7CB23DC-8C62-4500-8941-254AA8D2146B})
    5.102: Cg: Corresponding WWAN NDIS port found under \\.\GTNDIS0
    5.102: Cg: Searching for port [Diagnostics Interface] with parent 0xa18
    5.117: Cg: Checking port #0 [GlobeTrotter HSxPA - Application Interface (COM4)]
    5.117: Cg: Checking port #1 [GlobeTrotter HSxPA - Diagnostics Interface (COM5)]
    5.117: Cg: DevNode 0x133c status is 0x180600a, problem# is 0 (active)
    5.117: Cg: Corresponding debug port found on \\.\COM5 with devnode 0x133c
    5.117: Cg: Bus device found (\\.\gt72ubus0)
    5.897: Cg: Driver version: 4.0.0.18
    5.897: Cg: Card state changed to Started
    5.897: Cg: Detection timeout timer stopped
    5.897: Cg: Polling timer stopped
    5.897: CCgHelper::OwnCgInitialize, CgInitialize: OK.
    5.897: Cg: Sending notification, reason=1
    5.897: CSheetMain::OnCardStateChanged, UWM_CARD_STATE_CHANGED is fired.
    5.897: CSheetMain::OnCardStateChanged, Entered Critical Section
    5.897: CSheetMain::OnCardStateChanged, DebugPortName = \\.\COM5.
    5.897: CSheetMain::OnCardStateChanged, ApplicationPortName = \\.\COM4.
    5.897: CSheetMain::OnCardStateChanged, SmartCardReaderName = .
    5.897: CSheetMain::OnCardStateChanged, DebugPortName = \\.\COM5.
    5.897: CSheetMain::OnCardStateChanged, ApplicationPortName = \\.\COM4.
    5.897: CSheetMain::OnCardStateChanged, SmartCardReaderName = .
    5.897: CSheetMain::OnCardStateChanged, cardDriverCapabilities = 6f7.
    7.894: CSheetMain::OnCardStateChanged, Left Critical Section
    8.565: CCgHelper::RetrieveCardInfo, Entered CriticalSection!
    8.565: CCgHelper::RetrieveCardInfo, Left CriticalSection!
    8.565: CCgHelper::RetrieveCardInfo, returned: OK.
    8.565: CPagePreparation:o: Card state: 3.
    13.354: CPagePreparation:o, product: Icon 225.
    13.354: CPagePreparation:o, code: GI0225-11239.
    13.354: CPagePreparation:o: unsupported card (GI0225-11239).
    13.370: Cg: Notification window released
    13.370: Cg: Listener thread stopping
    13.370: Cg: Closing handle for listener thread 0x1770
    13.370: Cg: Card information database released
    13.370: CCgHelper::Cleanup, CgShutdown: OK.
    13.370: CCgHelper::Cleanup, CgLeaveExclusiveMode: OK.
    13.370: CPageWizard::ThreadDo, Do: 0xe0ff1001.
    23.369: CCgHelper::OwnCgUnInitialized, CgUnregisterListener: OK.

    **************************

    Can you please tell me how to proceed

    Thanks for help
  • #2

    No sorry, we do not have such service.

    Comment

    • #3

      Hello,

      After few hours of searching I've found the solution here:

      http://www.bez-kabli.pl/viewtopic.php?t=21291

      (use google translate)

      Easy to modify with hex editor.

      Comment

      Working...
      X